Issues with Billing
Incident Report for Livestream
Resolved
This incident has been resolved.
Posted Feb 15, 2017 - 12:22 EST
Update
Customers may see an error when attempting to view our platform pricing page while logged into their Livestream account (livestream.com/platform/pricing). We are continuing to monitor issues with our billing provider related to this. Thank you for your continued patience.
Posted Feb 15, 2017 - 11:47 EST
Investigating
Our billing provider is currently experiencing issues per their service health page. We are monitoring this closely and will update here with more information as soon as possible. All other areas of the Livestream website and platform are fully functional. Thank you for your patience.
Posted Feb 15, 2017 - 11:13 EST