Google-related services are down
Incident Report for Livestream
Resolved
This incident has been resolved.
Posted Dec 14, 2020 - 09:00 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2020 - 08:03 EST
Investigating
We are currently investigating this issue.
Posted Dec 14, 2020 - 07:18 EST
This incident affected: Platform Simulcast Feature (YouTube Live).