Downloading video archives results in an error page
Incident Report for Livestream
Resolved
The issue related to video downloads has been resolved.
Posted Apr 13, 2023 - 01:25 EDT
Investigating
We are currently investigating an issue where video downloads are generating a "site cannot be reached" error. Streaming and other site functions are unaffected.
Posted Apr 12, 2023 - 16:42 EDT
This incident affected: Platform.