Users are unable to download archives

Incident Report for Livestream

Resolved

This incident has been resolved.
Posted Aug 18, 2021 - 03:30 EDT

Investigating

We are currently investigating an issue preventing users from downloading archives.
Posted Aug 18, 2021 - 00:06 EDT
This incident affected: Platform.