Livestream and Mevo Support Phone Line Maintenance
Incident Report for Livestream
Resolved
The scheduled maintenance for our support phone lines was completed this morning, at 9:30am ET Friday, December 14th. The Mevo and Livestream phone support lines should now be open again during the usual hours of 9:30am-8:30pm EST, 7 days a week.

If you have any trouble calling in, please open an email ticket via the contact form at help.livestream.com or help.getmevo.com for assistance.
Posted Dec 14, 2018 - 12:39 EST
Monitoring
The Mevo and Livestream phone support lines will be closed due to a scheduled maintenance period starting at 6:00pm ET Thursday December 13th, and ending at 9:30am ET Friday, December 14th.

Customers are encouraged to open an email ticket via the contact form at help.livestream.com or help.getmevo.com for assistance.
Posted Dec 13, 2018 - 07:18 EST
This incident affected: Support (help.livestream.com) and Mevo Camera.