Phone Support Services Interruption
Incident Report for Livestream
Resolved
This incident has been resolved.
Posted Jul 19, 2018 - 14:27 EDT
Update
Our phone services provider is investigating an issue related to our phone system. If you're looking for support, please visit help.livestream.com and create a ticket. Thanks for your patience.
Posted Jul 19, 2018 - 11:38 EDT
Investigating
We are currently experiencing issues connecting with our phone support services. We will be sure to update as soon as we have more information.
Posted Jul 19, 2018 - 11:19 EDT
This incident affected: Support (help.livestream.com).