Phone provider outage

Incident Report for Livestream

Resolved

This incident has been resolved.
Posted Sep 09, 2018 - 10:47 EDT

Identified

Our phone provider is experiencing an outage, therefore, Livestream and Mevo customers may be unable to get through to our support team for phone support. We advise emailing our team for assistance in the interim.
Posted Sep 08, 2018 - 14:52 EDT