Youtube streaming through Mevo app temporarily disabled
Incident Report for Livestream
Resolved
This incident has been resolved.
Posted Jun 27, 2018 - 21:57 EDT
Identified
Youtube streaming through the Mevo app is temporarily disabled. We have identified the issue are are working on a fix.
Posted Jun 27, 2018 - 18:16 EDT
This incident affected: Support (help.livestream.com).