Phone Contact Services are currently interrupted
Incident Report for Livestream
Resolved
This incident has been resolved.
Posted Aug 03, 2017 - 09:36 EDT
Monitoring
Our telephone provider is currently experiencing service issues. Our Sales and Support Phone lines are currently not operational. We will keep this post updated as their service restoration progresses. Thank you for your patience.
Posted Aug 03, 2017 - 09:24 EDT
This incident affected: Support (help.livestream.com).